header-logo
Primi passiScopri come iniziare a costruire il tuo sito con Wix. Scegli un template e personalizzalo, o assumi un professionista per creare o far crescere la tua presenza online.
Creare il tuo sitoScopri come usare l'Editor Wix e gestire i contenuti del tuo sito. Proteggi la privacy dei tuoi visitatori e rendi il tuo sito accessibile.
Account e fatturazioneGestisci le impostazioni del tuo account, i tuoi abbonamenti e i pacchetti Premium, e scopri di più sulle tue fatture.
Usare le app mobile WixUsa l'app Wix per gestire la tua attività, comunicare con i tuoi visitatori e creare la tua community.
Collegare un dominioScopri come acquistare, collegare o trasferire un dominio, e come tenere i dati del tuo sito al sicuro.
Gestire la tua attivitàTrova gli strumenti giusti per costruire e far crescere la tua attività: accetta pagamenti, controlla le tue statistiche, gestisci i tuoi clienti e altro ancora.
Promuovere il tuo sitoScopri come promuovere il tuo sito sui motori di ricerca, inviare campagne email e pubblicare annunci a pagamento.
Studio, Partner ed EnterpriseOttieni il massimo dal tuo account Studio, Partner o Enterprise, e fai crescere la tua attività.
AssistenzaScopri come ottimizzare le prestazioni del tuo sito e risolvere problemi tecnici. Dai un'occhiata alle nuove funzionalità in arrivo nella Roadmap dei prodotti.
placeholder-preview-image
Wix LearnDiventa un esperto con i nostri corsi e tutorial.
Wix BlogScopri i consigli per web design, marketing e molto altro.
SEO Learning HubScopri come far crescere il traffico organico del tuo sito.
Website developmentCrea il tuo sito con la nostra piattaforma full stack.
Assumi un professionistaTrova un esperto che ti aiuti a raggiungere i tuoi obiettivi.
placeholder-preview-image
In questo articolo:
  • Modificare il layout dei menu a tendina
  • Personalizzare il design dei menu a tendina
  • (Menu orizzontali) Progettare singolarmente i menu a tendina

Editor Studio: progettare il design dei menu a tendina in un menu

In questo articolo:
  • Modificare il layout dei menu a tendina
  • Personalizzare il design dei menu a tendina
  • (Menu orizzontali) Progettare singolarmente i menu a tendina
Dopo aver aggiunto e configurato un menu a tendina, puoi personalizzarne il design in modo che appaia come desideri. Modifica l'aspetto e l'allineamento del contenitore e del menu per creare un look personalizzato per i clienti e rafforzare il loro brand. 
Prima di iniziare:
I menu a tendina possono essere aggiunti solo dai nuovi menu nell'Editor Studio. Se hai l'esperienza precedente dei menu, puoi creare i sottomenu e aggiungere i mega menu.

Modificare il layout dei menu a tendina

A seconda del tipo di menu (barra di navigazione, tre linee, ecc.), nel pannello Layout vengono visualizzate diverse impostazioni. Puoi anche personalizzare la spaziatura e l'allineamento per adattarli all'aspetto del menu principale.

Per modificare il layout dei menu a tendina:

  1. Vai al tuo Editor
  2. Clicca sull'icona della barra dei menu/menu a tre linee
  3. (Menu a tre linee) Clicca su Modifica menu per aprire la modalità di modifica a tre linee e seleziona il menu
  4. Clicca sull'icona Layout
  5. Seleziona la scheda Menu a tendina
  6. Usa le opzioni per regolare il layout:
Nota:
Le opzioni disponibili dipendono dal tipo di menu (barra di navigazione o tre linee) e dall'orientamento (orizzontale o verticale) scelto.
La scheda a tendina del pannello Layout menu. Il mouse sta cliccando su

Personalizzare il design dei menu a tendina

Puoi progettare ogni parte di un menu a tendina per completare l'aspetto del menu principale, dal contenitore agli elementi e ai sottoelementi. Scegli il riempimento dello sfondo e il testo per rafforzare il branding dei tuoi clienti e aggiungi bordi per far risaltare i menu a tendina sulla pagina.
Puoi anche personalizzare il design di elementi e sottoelementi per stati separati (es. passaggio del mouse, pagina corrente).

Per personalizzare il design dei menu a tendina:

  1. Vai al tuo Editor
  2. Clicca sull'icona della barra dei menu/menu a tre linee
  3. (Menu a tre linee) Clicca su Modifica menu per aprire la modalità di modifica a tre linee e seleziona il menu
  4. Clicca sull'icona Apri Ispezione  in alto a destra dell'Editor
Screenshot dell'apertura del pannello Ispezione nell'Editor Studio
  1. Seleziona l'elemento che vuoi progettare
    • Contenitore a tendina
    • Contenitore del menu a tendina
    • Elementi del menu a tendina
    • Sottoelementi del menu a tendina
  2. (Elementi a tendina/sottoelementi a tendina) Seleziona lo stato pertinente: RegolarePassaggio mouse o Pagina corrente/Selezionati 
  3. Progetta il design del menu a tendina utilizzando le opzioni disponibili:
    • Riempimenti sfondo: modifica il colore di sfondo del menu a tendina o aggiungi un gradiente accattivante. Puoi regolare l'opacità e aggiungere più livelli in base alle tue esigenze di design
    • Bordi: regola la larghezza e il colore dei bordi del contenitore a tendina
    • Angoli: rendi gli angoli del menu a tendina più arrotondati o rettangolari regolando il raggio
    • Testo: regola lo stile e la formattazione degli elementi del menu a tendina e dei sottoelementi 
    • Ombreggiatura: aggiungi ombre al menu a tendina e personalizzane l'angolo, il colore, la distanza e altro ancora 
Qual è la differenza tra i contenitori?
  • Contenitore a tendina: mostra tutti gli elementi e i menu che hai aggiunto all'elemento a tendina
  • Contenitore del menu a tendina: mostra solo gli elementi del menu a tendina. È posto all'interno del contenitore a tendina
L'ispezione è aperta. Il mouse sta cliccando sull'opzione di sottolineatura per gli elementi a tendina

(Menu orizzontali) Progettare singolarmente i menu a tendina

Le modifiche apportate a un menu a tendina vengono applicate a tutti i menu a tendina di quel menu. Vuoi creare qualcosa di più unico? Puoi "scollegare" i menu a tendina che hai aggiunto ai menu di navigazione orizzontale per avere il pieno controllo sul design.
Nota:
Questa opzione non è disponibile nei menu a tre linee o nei menu con barra di navigazione verticale.

Per scollegare e personalizzare i singoli menu a tendina nei menu orizzontali:

  1. Clicca sul menu orizzontale nell'Editor
  2. Clicca su Gestisci menu
  3. Passa il mouse sul menu a tendina pertinente e clicca su Modifica
  4. Scegli come vuoi progettare il design del menu a tendina: 
Nota:
Gli interruttori Modifica solo questo menu a tendina nel pannello Ispezione e nel pannello Layout sono collegati. Quando disabiliti/abiliti l'interruttore in uno di questi pannelli, questo si disabilita/abilita automaticamente anche nell'altro pannello.

Helpmate

Ciao

Hai bisogno di ulteriori suggerimenti?
Unlock personalized helpLog in to get the most out of Helpmate.